每人,每天,做好每件事
Everyone,Everyday,Everything

锐捷交换机RG-S2628G-I 通过 3 层核心交换机的IP转发能力实现子网互连

组网需求
如上图所示,某用户内网被划分为 VLAN 10、VLAN 20、VLAN 30,以实现相互间的 2 层隔离;3 个 VLAN 对应的 IP 子网
分别为 192.168.10.0/24、192.168.20.0/24、192.168.30.0/24,3 个 VLAN 通过 3 层核心交换机的 IP 转发能力实现子网互
连。
配置要点
本用例以核心交换机和 1 台接入交换机为例说明配置过程。要点如下:
 在核心交换机配置 3 个 VLAN,配置下连接入交换机的端口为 trunk 口,并指定许可 vlan 列表,实现 2 层隔离;
 在核心交换机配置 3 个 SVI 口,分别作为 3 个 VLAN 对应 IP 子网的网关接口,配置对应的 IP 地址;
 分别在 3 台接入交换机创建 VLAN,为各 VLAN 分配 Access 口,指定上连核心交换机的 trunk 口。本用例以接入交换
机 Switch A 为例说明配置步骤。

 

 

配置步骤
 核心交换机上的配置
创建 VLAN
# 进入全局配置模式
Ruijie#configure terminal
# 创建 VLAN 10
Ruijie(config)#vlan 10
# 创建 VLAN 20
Ruijie(config-vlan)#vlan 20
# 创建 VLAN 30
Ruijie(config-vlan)#vlan 30
# 退回到全局配置模式
Ruijie(config-vlan)#exit
配置各下连 trunk 口,指定许可 vlan 列表
# 进入端口范围 Gi 0/2-4
Ruijie(config)#interface range GigabitEthernet 0/2-4
# 配置该端口 Gi 0/2-4 都为 trunk 口
Ruijie(config-if-range)#switchport mode trunk
# 退回到全局配置模式
Ruijie(config-if-range)#exit
# 进入端口 Gi 0/2
Ruijie(config)#interface GigabitEthernet 0/2
# 将所有 vlan 从该端口的许可 vlan 中删除
Ruijie(config-if)#switchport trunk allowed vlan remove 1-4094
# 重新添加该端口的许可 vlan 为 10、20
Ruijie(config-if)#switchport trunk allowed vlan add 10,20
# 进入端口 Gi 0/3
Ruijie(config-if)#interface GigabitEthernet 0/3
# 将所有 vlan 从该端口的许可 vlan 中删除
Ruijie(config-if)#switchport trunk allowed vlan remove 1-4094
# 重新添加该端口的许可 vlan 为 10、20、30
Ruijie(config-if)#switchport trunk allowed vlan add 10,20,30
# 进入端口 Gi 0/4
Ruijie(config-if)#interface GigabitEthernet 0/4
# 将所有 vlan 从该端口的许可 vlan 中删除
Ruijie(config-if)#switchport trunk allowed vlan remove 1-4094
# 重新添加该端口的许可 vlan 为 20、30
Ruijie(config-if)#switchport trunk allowed vlan add 20,30
# 退回到全局配置模式
Ruijie(config-if)#exit
在核心交换机上查看 vlan 配置
# 查看 vlan 信息,包括 vlan id、名称、状态、包括的端口
Ruijie#show vlan
VLAN Name Status Ports
—- ——– ——– ——————————-
1 VLAN0001 STATIC Gi0/1, Gi0/5, Gi0/6, Gi0/7
Gi0/8, Gi0/9, Gi0/10, Gi0/11
Gi0/12, Gi0/13, Gi0/14, Gi0/15
Gi0/16, Gi0/17, Gi0/18, Gi0/19
Gi0/20, Gi0/21, Gi0/22, Gi0/23
Gi0/24
10 VLAN0010 STATIC Gi0/2, Gi0/3
20 VLAN0020 STATIC Gi0/2, Gi0/3, Gi0/4
30 VLAN0030 STATIC Gi0/3, Gi0/4
# 查看端口 Gi 0/2 的 vlan 状态
Ruijie#show interface GigabitEthernet 0/2 switchport
Interface Switchport Mode Access Native Protected VLAN lists
——– ———- —– —— —— ——— ———
Gi0/2 enabled TRUNK 1 1 Disabled 10,20
# 查看端口 Gi 0/3 的 vlan 状态
Ruijie#show interface GigabitEthernet 0/3 switchport
Interface Switchport Mode Access Native Protected VLAN lists
——– ———- —– —— —— ——— ———-
Gi0/3 enabled TRUNK 1 1 Disabled 10,20,30
# 查看端口 Gi 0/4 的 vlan 状态
Ruijie#show interface GigabitEthernet 0/4 switchport
Interface Switchport Mode Access Native Protected VLAN lists
——– ———- —– —— —— ——— ———-
Gi0/4 enabled TRUNK 1 1 Disabled 20,30
创建 SVI 口,指定 IP 地址
# 进入全局配置模式
Ruijie#configure terminal
# 创建 SVI 10
Ruijie(config)#interface vlan 10
5-11
配置指南 VLAN
# 配置 SVI 10 的 IP 地址
Ruijie(config-if)#ip address 192.168.10.1 255.255.255.0
# 创建 SVI 20
Ruijie(config-if)#interface vlan 20
# 配置 SVI 20 的 IP 地址
Ruijie(config-if)#ip address 192.168.20.1 255.255.255.0
# 创建 SVI 30
Ruijie(config-if)#interface vlan 30
# 配置 SVI 30 的 IP 地址
Ruijie(config-if)#ip address 192.168.30.1 255.255.255.0
# 退回到全局配置模式
Ruijie(config-if)#exit
 接入交换机 Switch A 上的配置
创建 VLAN
# 进入全局配置模式
Ruijie#configure terminal
# 创建 VLAN 10
Ruijie(config)#vlan 10
# 创建 VLAN 20
Ruijie(config-vlan)#vlan 20
# 退回到全局配置模式
Ruijie(config-vlan)#exit
 为各 VLAN 分配 Access 口
# 进入端口范围 Gi 0/2-12
Ruijie(config)#interface range GigabitEthernet 0/2-12
# 将端口 Gi 0/2-12 配置为 Access 口
Ruijie(config-if)#switchport mode access
# 将端口 Gi 0/2-12 分配给 VLAN 10
Ruijie(config-if)#switchport access vlan 10
# 进入端口范围 Gi 0/13-24
Ruijie(config-if)#interface range GigabitEthernet 0/13-24
# 将端口 Gi 0/13-24 配置为 Access 口
Ruijie(config-if)#switchport mode access
# 将端口 Gi 0/13-24 分配给 VLAN 20
Ruijie(config-if)#switchport access vlan 20
# 退回到全局配置模式
Ruijie(config-if)#exit
指定上连核心交换机的 trunk 口
# 进入端口 Gi 0/1
Ruijie(config)#interface GigabitEthernet 0/1
# 配置该端口 Gi 0/1 都为 trunk 口
Ruijie(config-if)#switchport mode trunk
# 退回到全局配置模式
Ruijie(config-if)#exit

 

赞(0) 打赏
未经允许不得转载:辣椒小鱼のBlog » 锐捷交换机RG-S2628G-I 通过 3 层核心交换机的IP转发能力实现子网互连
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

×
订阅图标按钮