每人,每天,做好每件事
Everyone,Everyday,Everything

锐捷交换机RG-S2628G-I DHCP 典型配置用例

应用需求
 Host A 可以作为 DHCP Server 为一部分客户端用户分配动态 IP 地址。可分配地址的网段为 172.16.1.0/24,缺省网关
为 172.16.1.254,域名为 ruijie.com,域名服务器为 172.16.1.253,WINS 服务器为 172.16.1.252,NetBIOS 节点类
型为复合型,地址租期为 1 天。在地址的网段中除了 172.16.1.2~172.16.1.100 地址外,其余地址均为可分配地址。
 Host A 为一部分客户端用户分配固定 IP 地址。对 MAC 地址为 00d0.df34.32a3 的 DHCP 客户端分配的 IP 地址为
172.16.1.101,掩码为 255.255.255.0,主机名为 admin,缺省网关为 172.16.1.254,域名服务器为 172.16.1.253,
WINS 服务器为 172.16.1.252,NetBIOS 节点类型为复合型。
 HOST B 为设备接口 FastEthernet 0/0 配置 DHCP 自动分配地址。
配置要点
 在 Host A 上开启 DHCP 服务器功能,创建一个地址池,用于配置动态分配 IP 地址,另外创建一个地址池,用于手工
绑定 IP 地址。并在相应的地址池指定域名服务器地址(本例为 DNS Server 和 WINS Server 的地址)以及客户端的域
名。
 在 Host B 上指定接口开启 DHCP 客户端功能,自动获取 IP 地址。

配置步骤
第一步,在 Host A 上,创建新的 DHCP 地址池,配置动态分配 IP 地址。
!配置地址池名为“dynamic”,并进入 DHCP 配置模式。
HostA# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
HostA(config)# ip dhcp pool dynamic
!在 DHCP 配置模式下,配置一个可分配给客户的 IP 地址网段,并配置该地址网段的默认网关。并设置租期为 2 天。
HostA(dhcp-config)# network 172.16.1.0 255.255.255.0
HostA(dhcp-config)# default-router 172.16.1.254
HostA(dhcp-config)# lease 2
第二步,指定“dynamic”地址池的 DNS Server,并配置客户端的域名。
!假设 DNS Server 的 IP 地址是 172.16.1.253,在地址池中配置域名服务器,并配置客户端域名为 ruijie.com。
HostA(dhcp-config)# dns-server 172.16.1.253
HostA(dhcp-config)# domain-name ruijie.com
第三步,指定“dynamic”地址池的 WINS Server,并配置客户端 NetBIOS 节点类型。
!假设 WIN Server 的 IP地址是 172.16.1.252,在地址池中配置 NetBIOS WINS服务器,并配置 NetBIOS 节点类型为Hybrid。
HostA(dhcp-config)# netbios-name-server 172.16.1.252
HostA(dhcp-config)# netbios-node-type h-node
第四步,在全局模式下配置排斥地址。
!如上,IP 地址为 172.16.1.254、172.16.1.253、172.16.1.252 已经分配作为对应网段的网关、DNS 服务器、WINS 服务
器的地址,并且地址范围 172.16.1.2~172.16.1.100 也不允许分配。通过排斥地址配置明确这些地址不允许分配给客户端用
户。
HostA(dhcp-config)# exit
HostA(config)# ip dhcp excluded-address 172.16.1.252 172.16.1.254
HostA(config)# ip dhcp excluded-address 172.16.1.2 172.16.1.100
第五步,创建另一个地址池,配置手工绑定 IP 地址。
!配置地址池名为“static”,并进入 DHCP 配置模式。
HostA(config)# ip dhcp pool static
! 指明 IP 地址为 172.16.1.101/24 手工绑定 MAC 地址为 00d0.df34.32a3,客户端名称为 admin。注意:定义客户端的标
识需增加网络媒介类型标识(以太网类型为“01”),即手工绑定的 MAC 地址对应的客户端标识为 00d0.df34.32a3.14。
HostA(dhcp-config)# host 172.16.1.101 255.255.255.0
HostA(dhcp-config)# client-identifier 00d0.df34.32a3.14
HostA(dhcp-config)# client-name admin
第六步,指定“static”地址池对应的网关地址。
!配置网关地址为 172.16.1.254。
HostA(dhcp-config)# default-router 172.16.1.254
第七步,指定“static”地址池的 DNS Server,并配置客户端的域名。
!同上,假设 DNS Server 的 IP 地址是 172.16.1.253,在地址池中配置域名服务器,并配置客户端域名为 ruijie.com。
HostA(dhcp-config)# dns-server 172.16.1.253
HostA(dhcp-config)# domain-name ruijie.com
第八步,指定“static”地址池的 WINS Server,并配置客户端 NetBIOS 节点类型。
!同上,假设 WIN Server 的 IP 地址是 172.16.1.252,在地址池中配置 NetBIOS WINS 服务器,并配置 NetBIOS 节点类型
为 Hybrid。
HostA(dhcp-config)# netbios-name-server 172.16.1.252
HostA(dhcp-config)# netbios-node-type h-node
HostA(dhcp-config)# exit
第九步,在 Host A 上启用 DHCP Server。
HostA(dhcp-config)# exit
HostA(config)# service dhcp
第十步,在 Host B 上启用 DHCP Client。
!此例默认客户端的接口为三层口,启动 DHCP client。
HostB(config)# interface fastEthernet 0/1
HostB(config-if-fastEthernet 0/1)# ip address dhcp
验证结果
第一步,查看 Host A 的配置信息

HostA# show running-config
!
service dhcp
!
ip dhcp excluded-address 172.16.1.252 172.16.1.254
ip dhcp excluded-address 172.16.1.2 172.16.1.100
!
!
ip dhcp pool dynamic
netbios-node-type h-node
netbios-name-server 172.16.1.252
domain-name ruijie.com
lease 2 0 0
network 172.16.1.0 255.255.255.0
dns-server 172.16.1.253
default-router 172.16.1.254
!
ip dhcp pool static
client-name admin
client-identifier 00d0.df34.32a3.14
host 172.16.1.101 255.255.255.0
netbios-node-type h-node
netbios-name-server 172.16.1.252
domain-name ruijie.com
dns-server 172.16.1.253
default-router 172.16.1.254
!

第二步,查看 Host B 的配置信息

HostB# show running-config
!
interface fastEthernet 0/1 //注:如果是交换机设备,这里应该还有 no switchport 命令,将接口设置为三层口
ip address dhcp

第三步,接入一台 MAC 地址为 0013.2049.9014 的 PC,在 Host A 上查看 DHCP Server 分配 IP 地址信息。

Ruijie#show ip dhcp binding
IP address Client-Identifier/ Lease expiration Type
Hardware address
172.16.1.101 00d0.df34.32a3.14 IDLE Manual 172.16.1.102 0100.e04c.70b7.e2 000
days 23 hours 48 mins Automatic

 

赞(0) 打赏
未经允许不得转载:辣椒小鱼のBlog » 锐捷交换机RG-S2628G-I DHCP 典型配置用例
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

×
订阅图标按钮